Trimble - Transforming the way the world works.

January, 2017

The following enhancements have been added to AutoBid Mechanical 2016v1.

New User Interface

This release introduces a new user interface, which provides better navigation throughout the application and is referred to as the Navigation Screen. Bid-specific modules are located at the top (yellow); master modules are located below (blue). Speed buttons are still supported.

Microsoft® SQL Server® Database

The AutoBid Mechanical 2016v1 database has been migrated to a Microsoft SQL Server format. Some reasons for the change are:

  • Microsoft SQL Server is an enterprise level database and is highly regarded in the industry.
  • Microsoft SQL Server has enhanced database integrity and stability.
  • You should see improved speed in multi-user situations.
  • Microsoft SQL Server has greater interoperability support.
  • Microsoft SQL Server has enhanced support for multiple databases, for instance an imperial and a metric database.

Backup/Restore Enhancements

The Backup and Restore process has been modified as follows:

  • Projects, Piping/Library Items, Labor - Backing up and restoring projects, piping items, library items, and labor are handled within the AutoBid Mechanical Navigation Screen (under the File menu).

  • Full Database Backups - Full database backups are now created at the server level. You must perform these on the computer where the Microsoft SQL Server is installed. The database backup is significantly faster and no longer requires all users to be out of the program.

  • Scheduled Backup - Scheduled Backups are now available from the Navigation Screen (under the Tools menu). You can set a time for a daily backup.

On-Screen View TakeOff

You now have the option to undock the Audit Trail while in On-Screen View (OSV) TakeOff and position it anywhere on the primary monitor OR relocated it to another monitor (if available). You can do this from the View menu or by right clicking on the Audit Trail and selecting UnDock Audit Trail. This feature provides flexibility and more workspace to view your on-screen drawing. Once it is undocked, you can also choose to have it always stay on top.

Creating Variables in Assemblies

This release contains the following enhancements for creating variables in assemblies:

  • A new Variables tab has been added to the Assembly screen. This tab allows you to create variables and prompts that display when you take off the assembly. Variables were previously located on the General Tab.
  • You can set up your variable using TakeOff Methods:
    • TakeOff as an Assembly Dimension - Selecting this open will prompt a dimension to be entered during TakeOff. You can also enter a Dimension Hint, if desired. This displays on- screen when you take off the assembly as well.
    • Prompt when the Assembly is Taken Off - When you select this option button, you must enter text in the Prompt When Taken Off field. The text you enter in this field displays in an on- screen prompt when you take off the assembly.
    • If Statements - You can now create If Statements in your assembly using additional parameters. The options are:
      • Equal to Greater than
      • Greater than or equal to In Range
      • If it is Yes If it is No
      • Less than or equal to NOT equal to
    • Assembly Box-In Connectivity - This release adds enhanced ‘connectivity’ to assemblies created in OSV using the ‘Box-In’ feature to create the assembly. This results in more accurate calculations. This enhancement only applies to assemblies created in this version or later. In previous versions, when creating an assembly, the reducing branch connectivity was not maintained when using the Box-In tool.

Reports

  • The reports have been completely upgraded and are now using a newer and more dynamic reporting tool. While the reports will have the same content as they did in previous releases, they will have enhanced viewing and exporting capabilities. Additionally, you can now have more than one report open at the same time.

Note – If your company is currently using a customized Crystal Report, you will need to contact support to have the report converted to the new format.

  • A new tab called Trace Intermediate Calculations has been added to the Reports screen. This tab becomes visible by selecting the Trace Intermediate Calculations checkbox prior to starting calculations. This new feature is a “trace” or log file that appears after calculations to show step by step “how” AutoBid Mechanical resolved Specifications, Material Pricing and Labor. The log file is limited to 6,000 lines of output, which represents about 100 lines of TakeOff. This might be used as a teaching tool to help users setting up new specifications or to examine how current specifications are performing.
  • G&A taxes on the Summary tab in the Rapid Reports template now calculate more accurately.
  • A new option has been added to Reports that will hide Missing Price and Labor Warning (#102). You can access this option by selecting More Options menu from the Calculation Summary dialog.
  • Yellow highlighting has been added to the error log stating the Number of items that still are missing price or labor.

Bid Specific Material Multipliers

A new feature has been added to the bid specific Material Multiplier form. This feature expands on a very powerful feature called Vendor Pricing. If the Vendor Pricing feature is unfamiliar to you, you can find three videos (Vendor Pricing Parts 1, 2 and 3) explaining this feature. To access the videos from the Navigation Screen, click the Help menu and select What’s New Video Tutorials.

There is a new Vendor Pricing option called Show accepted Vendor quotes. The option is located on the bottom right side of the form. When checked, the Material Multipliers grid shows the accepted vendor quotes in lieu of the pricing (list price + multiplier). That grid row is highlighted and read-only. You will only see this after completing the Vendor Pricing.

Copying Specifications

Enhancements have been made to the copying specifications functionality so that it now works as you would expect it to. As in previous releases, specifications from the source project will overwrite those in the target project. While some copy from options are no longer available from within TakeOff, you can access them all from within the Setup Project dialog.

This release also includes a new power merge feature which allows you to merge join-to-joint references from one project into another. Rather than overwriting what is currently in the target project, this new function allows you to add new joint-to- joint references and update existing ones.

Please refer to the Copying Specifications video for more details on these changes.

New Filter Functionality

You now have the ability to apply a filter to the list of Master Material Multipliers. This functionality applies to other screens as well. This has replaced the Find/Find Next functionality that was available in previous releases. The screenshots below illustrate how this feature works.

 

Additional Enhancements

  • While working in Labor Books Explorer, if you need to leave and then reopen the form, the previous selection in the tree is retained. This works the same as it has in Piping Items.
  • You now have the ability to customize the mousemenu to include System and Specification Name.
  • A new option allowing you to ignore the list pricing from Trade Service has been added to the Piping Items form. This can be useful if pricing on a volatile item is maintained by your company. This feature is applied on an individual item level.
  • AutoBid Mechanical no longer supports Audit Trail View (ATV) "Classic" view. However, there is now a Custom View option in ATV to display the Audit Trail List on the left and the Details on the right side of the screen.
  • This release contains enhancements to handle higher DPI settings. However, because screen display can be affected by video hardware, drivers, and operating system settings, each system is unique. If you continue to have DPI problems Trimble recommends that you go back to 96 DPI or change the size of text, apps, and other items to 100%.

Database Modifications

This release of AutoBid Mechanical includes the following additional items which are available to add to your database:

Commonly-Used Hilti Products

  • Anchors
    • Injectable Adhesive
    • Capsule Adhesive
    • Expansion Type
    • Flush Type
  • Fire Stopping
    • Foams
    • Mortars
    • Putties
    • Sealants
  • Hanger Components
    • Riser Clamps
    • Beam Clamps
    • Split Ring Hangers
    • Clevis Hangers
    • Pipe Rings
    • Threaded Rod
    • Hex Nuts
    • Hex Bolts
    • Washers
  • Channel Systems
    • Various Gauges and Materials
    • Associated Fittings and Support

Labor Updates

  • Latest MCAA labor unit updates
  • AutoBid Mechanical standard labor unit updates to be more in line with how the WebLEM aligns labor to specific items. This is primarily for HVAC specialties and equipment

WebLEM Updates

  • Ball Joints
  • Aquatherm PP Pipe and Fittings
  • CPVC Valves
  • PVC Valves

PEX - Uponor

  • Latest Tubing and Fittings
  • Library Items
    • Accessories
    • Controls and Thermostats
    • Manifolds

Aquatherm

  • Green, Blue and Lilac piping
  • All Associated Fittings
  • Accessories

Figure 870 Victaulic Steam Coupling Weldbend

  • Schedule 160 and Double Extra Heavy Buttweld Fittings

 

 

The restore item function now allows you to restore piping items by material. Additionally, you can now select particular libraries to restore.

You can restore new items and labor from the new user data.zip files found on your DVD and in C:\ProgramData\Trimble\ABMC\Master\DB\ABMC 2016v1 New Data\US. In that directory, you will also find a spreadsheet containing detailed information on the new and updated data. You can use that spreadsheet to help determine which materials and libraries you would like to restore. You will find a detailed video describing the process, if you follow the Restoring New Materials and MCA Labor Updates link in the What’s New Videos.