Trimble - Transforming the way the world works.

June, 2012

This release includes modifications to the default QuickPen database. These changes can be  incorporated into your database by using the restore feature in AutoBid Mechanical. refer to the  Adding Updated Data topic below for more information.

Note: Trimble Quick Link and AutoBid Mechanical, Release 2012 v1, must be installed  with communication configured prior to adding the updated data to your system.  Detailed information is included in the Update Installation Instructions document  available on the installation DVD.

Database Enhancements

If you have any questions on how to use this new default data, please contact our technical  support department.

Adding Updated Data

Note: Keep the following in mind before beginning the processes outlined below:

  • Perform a full system backup before performing the tasks outlined below.
  • During the restore process, if you are installed on a network, everyone (all  workstations) must be logged out of AutoBid Mechanical!
  • This process will take a substantial amount of time to complete.
  • Please be aware that some database maintenance will be required if you choose  to update the MCAA tables.

The instructions below provide you with step-by-step instructions to update and locate  any broken labor links that may result from updating the tables.

  1. You will need the AutoBid Mechanical, Release 2012 v1, installation DVD to complete  the processes outlined in this section. Insert it into the appropriate drive of your  computer.
  2. Open AutoBid Mechanical and go to File > Restore.
  3. Click Browse and navigate to the installation DVD. Open the Backups folder and click  United States or Canada (depending on your location and/or the type of data you are  updating). Double-click on the New User Data zip file. Click Next.

MCAA Labor Book Update

1. Click Specific and then select Labor Books (individual books) from the list. Make sure  the Overwrite radio button is selected.

mcaa labour book update

 

Click Next.

2. Click the MCA checkbox and make sure that MCA is selected.

labour book update

Click Restore.

3. The restore process begins. A progress indicator displays on-screen during the update. Do  not click Cancel during this procedure!

4. Close and reopen AutoBid Mechanical. Note: This is required in order for the  program/database to recognize the update system-wide.

Piping Items Update

For the AutoBid Mechanical database to fully recognize the changes made in the MCAA Labor  Book, updating Piping Items is also required. These instructions assume you have the AutoBid  Mechanical installation DVD in the appropriate drive of your computer.

1. Open AutoBid Mechanical and go to File > Restore.

2. Click Browse and navigate to the installation DVD. Open the Backups folder and click  United States or Canada (depending on your location and/or the type of data you are  updating). Double-click on the New User Data zip file. Click Next.

3. Click Specific and then select Piping Items from the list. Make sure the Update radio  button is selected. Click Next.

4. Select the Add new tables and update existing radio button.

piping item update

Click Next.

5. In the Overwrite pane, select the Labor Links checkbox.

piping update options

Click Next.

6. Click the MCA checkbox and make sure that MCA is selected in the list.

autobid mechanical update options

Click Finish.

7. The update process begins. A progress indicator displays on-screen during the update. Do  not click Cancel during this procedure! When the update is complete, a report displays  on-screen. This report provides information pertaining to the items updated. QuickPen  recommends that you review the report before proceeding. You can save it to a file or  print it from this window.

8. Close and reopen AutoBid Mechanical. Note: This is required in order for the  program/database to recognize the update system-wide.

Broken Labor Links

Please be aware that some database maintenance will be required if you choose to update the  MCAA tables. You may find missing labor links due to the changes incorporated into this  release. You are strongly encouraged to use the Tools > Find Broken Labor Links tool in the  Labor Books module prior to creating or working on bids. This will locate and allow you to  correct any broken links. Keep in mind that this process may take a substantial amount of your  time.

New Default Project

If you wish to add the new default project to your existing database, proceed as follows. Note:  These instructions assume you have the AutoBid Mechanical installation DVD in the appropriate  drive of your computer.

  1. Open AutoBid Mechanical and go to File > Restore.
  2. Click Browse and navigate to the installation DVD. Open the Backups folder and click  United States or Canada (depending on your location and/or the type of data you are  updating). Double-click on the New User Data zip file. Click Next.
  3. Click Projects and then click Next.
  4. In the Select Projects to Restore window, click on the AAA Standard Project.
  5. Click Restore.

AutoBid® Mechanical  2012 v1 Release Highlights

The AutoBid Mechanical system enhancements offer customers the following new features and  enhancements:

Trimble® Quick Link

Note: Due to licensing considerations, Trimble Quick Link is required in order to use  AutoBid Mechanical. Installation of the Trimble Quick Link software is covered in the  AutoBid Mechanical Update Installation Instructions document.

This release of AutoBid Mechanical includes an interface with Trimble Quick Link, a licensing  and communication software application. Benefits of this software application are:

  • Virtual Computer Users -  If you have AutoBid Mechanical installed on a virtual machine, you no longer have to  contact Technical Support to renew your licenses every 90 days.
  • Technical Support Tickets -  You can send Technical Support requests by using the Quick Link communication  feature in AutoBid Mechanical (see below for more information). This automatically  adds your request to the QuickPen support queue.
  • Easier License Check-Out Functionality -  To checkout or borrow a license, all you need is an initial internet connection and proper  security (Login name and Password).
  • License Administration Control -  Using the Trimble® Quick Link Management Studio, you can view license availability,  update licensing, and obtain new licensing.
  • Server Moves -  In the event you need to move AutoBid Mechanical from one server to another, you can  easily accomplish this without contacting QuickPen Technical Support for licensing  issues.
  • Share licenses -  Licenses can be shared between multiple offices; however, the Trimble® Quick Link  Hub must be installed at all locations.

Technical Support Ticket

When you have questions or issues requiring contact with QuickPen Technical Support, you can  simply enter these and the Trimble Quick Link software application sends your request, adds it to  the QuickPen Technical Support queue, and creates a support ticket. You will be contacted in a  timely manner by a Technical Support Representative to discuss your request.

1. Go to the Help menu in the main AutoBid Mechanical or TakeOff window. Note: The  graphic below illustrates the Help menu in the main AutoBid Mechanical window.

support ticket for autobid mechanical

 

2. Click Send message to Technical Support.

3. In the Send message to QuickPen Technical Support dialog, enter your Question/Issue.

If desired, click on the Screen Shot tab and paste an applicable shot illustrating the  Question/Issue.

On-Screen View TakeOff

Named Views

This release of AutoBid Mechanical includes a new feature that allows you to save a TakeOff  view

Named Views

 

  • When you have your desired view set, go to View > Save Current View and name the  view.
  • The saved views are saved and available in  the List of named views window. You can  then select specific views in your drawing.

list of named views

 

This feature may prove especially helpful if you have a drawing with notes. You can zoom in  on the notes and save the view. As you are taking off your drawing and come across a note,  you can quickly switch over to the "notes view", read the notes, and quickly go back to the  previous view to continue your take off.

You can also add the menu shortcuts to your Smart Menu™ by GTCO and your  MouseMenu. This will make it even more convenient to move between views while working  in TakeOff.

Annotations (Sticky Notes)

The AutoBid Mechanical software offers a new feature that allows you to add notes to your  On-Screen View TakeOff drawing. The default setting is to display all notes; you have the

option of hiding the notes, if desired, under the View menu in On-Screen View TakeOff.

trimble autobid annotations

Clicking on the command toggles the  display on and off.

  • A checkmark displays next to the  command when active.
  • No checkmark is present when the  command is inactive.

You can easily add a note by clicking on the toolbar. Draw a box where you want to  place your note. You can then enter notes within the box.

annotations

 

  • You can move the note box by clicking on it and then dragging to another location.
  • You can resize the note box by clicking on the bottom, right, or lower right corner and dragging in-or-out.

OR

  • You can right-click in the box and then select Resize Note from the pop-up menu.

resize sticky note

 

You can change font and define note options by right clicking in the box and then  clicking Change Note Settings from the pop-up menu.

sticky note settings

 

  • You can include Sticky Notes when printing your TakeOff (File > Print).
  • When a note is selected, you can add new or edit existing text. The note is selected  when you move your mouse over the note.
  • Notes are included when backing up your database or exporting your project.

Note: Notes will not be included when merging TakeOffs.

Rotate with Copy/Move

When processing copy or move functions, AutoBid Mechanical, Release 2012 v1, allows you  to rotate your items at 45º or 90º.

copy and move options

 

When you make your Copy/Move selection, you can specify the following in the Options  pane:

  • Keep the same orientation
  • Mirror (X or Y axis)
  • Rotate (45º or 90º - clockwise or counter-clockwise)

On-Screen View/Audit Trail View TakeOff

The following enhancements are now available in both On-Screen View and Audit Trail View  TakeOff.

Floating Assembly/Symbol Windows

This release of AutoBid Mechanical includes the ability to have assembly and symbol  windows open and "floating" in the On-Screen View and Audit Trail View TakeOff  windows.

 

On-Screen View TakeOff

floating assembly / symbol windows

Audit Trail View TakeOff

graphical view

This feature saves you time when working in TakeOff. You can simply drag the item from  the floating window to your drawing or Audit Trail.

  • You can have more than one floating window open at any given time.
  • The windows contain only those assemblies/symbols in the current project.
  • The symbol list includes symbols and their descriptions.

symbols

The Assembly list includes the name.

assemblies

Filtering in both lists is available.

Note: Items without a dimension will be added automatically to your TakeOff. If  a dimension is required, the Item window opens allowing you to enter the  appropriate information before you continue.

General TakeOff

"Undo" Functionality

TakeOff now offers a limited "Undo" feature that allows you to undo specific items in  TakeOff.

The "Undo" feature must be activated under Tools > Options. Note: Because this option may  slow processing in TakeOff, this option is off by default. See the online help system for more  information.

takeoff options

 

When the "Undo" feature is activated, and you perform tasks that allow this functionality,  you can access the command under the Edit menu. The graphic below illustrates the menu  with undoing a single deleted line command.

undo feature

 

TakeOff retains a record of the items/lines you have added to your take off until you perform  a task that resets the log (for instance, changing TakeOff methods or modifying any filtering  set in your TakeOff). If you find you need to "undo" something other than the last thing you  did, you can choose Edit > Undo – multiple. The Undo Through window displays.

autobid mechanical undo options

 

AutoBid Mechanical keeps a log of all  items taken off. Note: The log is cleared  under certain circumstances, including  but not limited to:

  • Change TakeOff methods (views)
  • Modify filters
  • Exit TakeOff

You can click on an item in the list and then click Undo. Keep in mind that you must  undo items sequentially. For example, if you have 10 items in your list and you want  to undo the third and sixth item, you must undo the first through fifth tasks also. You  cannot simply undo the third and sixth task.  You can also right-click and select Undo All in the Undo  Through window.

Additional Modifications

Material Price Override

This release of AutoBid Mechanical includes a new option in the Reports module to export  material price data to a Microsoft® Excel® spreadsheet.

material price override

 

To open the Material  Price Override module,  click on the Reports  toolbar

This powerful feature allows you to:

  • Filter and export only those items for vendor quotes; for example, you might always  obtain quotes on Carbon Steel items. This feature makes it easy to obtain quotes only on  those items.
  • Send a spreadsheet to vendors for completion and then import this data into the AutoBid  Mechanical database.
  • Obtain multiple price quotes for the same items by sending the spreadsheet to several  preferred vendors. You can then review each and import only the pricing desired.
  • Quickly add various vendor quotes to the AutoBid Mechanical database using the import  functionality.
  • Periodically verify prices with vendor. Simply export the data and provide the  spreadsheet to the vendor for review.
  • Export final prices to the spreadsheet to capture prices used on bid day for future  reference.

The Material Price Override window includes various columns that are grouped together.  Some contain data exported from the material pricing tables (non-editable); others are  available for completion by you or by importing your vendor's information from the Excel  spreadsheet.

material price quote

 

material price quote 2

After you have created the data export file (illustrated above), select the data you want  included in the spreadsheet and then click on the toolbar.

export to excel from autobid mechanical

 

Select a  location and file name. This spreadsheet can then be sent to a vendor for price completion.  When the vendor has completed entering Net Unit Price information in the  preadsheet, it is  sent back to you. After you have reviewed pricing, you can then import the data into AutoBid  Mechanical, saving you input time and eliminating errors. After you  save imported pricing  into your database, you must rerun calculations for the modifications to take effect.  The online help system includes detailed information on using this new feature. You can  access help by pressing F1 in any of the windows associated with the Material Price  Override.